Technical Questions
 Crystal Reports Forum : Crystal Reports 9 through 2022 : Technical Questions
Message Icon Topic: Crystal Enterprise 8.0 APS Service will not start Post Reply Post New Topic
Author Message
shardstaff
Newbie
Newbie


Joined: 13 May 2014
Online Status: Offline
Posts: 1
Quote shardstaff Replybullet Topic: Crystal Enterprise 8.0 APS Service will not start
     Posted: 13 May 2014 at 4:29am
We are testing a domain move on our crystal enterprise 8.0 server after changing the domain name and server name we can't start the APS service and we don't have the media to re install the server as it's soooo old and someone had had a clear out

it's installed on a Windows 2003 r2 server with service pack 2 it was working fine till we change the domain and server name I have been through the registry and changed the server and domain names and renamed the files and folders all the other services start but state (Failed to register with the APS OUR_NEW_SERVER_NAME. Please make sure the APS is up and running. Attempting an automatic retry...)

When I try to start the Crystal APS I get the information records in the app log stating connecting to access db ect and I can see the access lock file created so the service is opening that db

The error we get in the sever app log are below

1st Failed to register object "com.seagatesoftware.img.osca.aps."OUR_NEW_SERVER_NAME":aps" to the name server. Reason: Transport user error: invalid object name..

2nd Failed to register the APS to the name server.

3rd The root server reported an error Initialization Failure.

The error in the C:\Program Files\Seagate Software\logging is this

Timestamp (Process ID, Thread ID), (Event Type, Category, Event ID), Information:
11:29:13 (1376, 1924), (1, 1, 33009), Info: assert failure (Y:\ashwin\apssrvr5.cpp513). (ret || (op != CNameServerManager::Bind && op != CNameServerManager::Rebind) || CompareStringsNoCase(kind, NativeChar_Services::OCA_APSServer) != 0 : ).
Call Stack Dump: Not available
11:29:13 (1376, 1924), (1, 1, 33009), Info: assert failure (Y:\ashwin\apssrvr5.cpp401). (0 : ).
Call Stack Dump: Not available
11:29:13 (1376, 1924), (1, 1, 33009), Info: assert failure (Y:\ashwin\apssrvr.cpp1202). (0 : ).
Call Stack Dump: Not available
11:29:13 (1376, 1924), (1, 1, 33009), Info: assert failure (Y:\ashwin\apssrvr.cpp959). (0 : ).
Call Stack Dump: Not available

We don't have a Y: and I can't find any reference to any part of the path in the registry Y:\ashwin\apssrvr5.cpp401

Any help would be very kindly received

Simon
IP IP Logged
Erik
Groupie
Groupie
Avatar

Joined: 05 Dec 2013
Online Status: Offline
Posts: 50
Quote Erik Replybullet Posted: 18 Jun 2014 at 5:50am
If Y: doesn't come up with a search in Registry Editor you might try doing a "find" from cmd prompt where the configuration files live.

FIND /I "ashwin" *.* > results.txt
IP IP Logged
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum