Technical Questions
 Crystal Reports Forum : Crystal Reports 9 through 2022 : Technical Questions
Message Icon Topic: Segmentation fault in Crystal Reports Server Post Reply Post New Topic
Author Message
marvins
Newbie
Newbie


Joined: 09 Feb 2010
Online Status: Offline
Posts: 3
Quote marvins Replybullet Topic: Segmentation fault in Crystal Reports Server
     Posted: 09 Feb 2010 at 8:01am
Dear all,

I tried to install Crystal Reports Server 2008 on SUSE Linux Enterprise Server 10 64 bit. The installation was going fine until it reached 53% and displayed this error message:

sh: line 1: 5633 Segmentation fault "/<INSTALL_DIR>/bobje/enterprise120/linux_x86//boe_cmsd" -name crs.cms -loggingPath "/<INSTALL_DIR>/bobje/logging/" -pidFile "/<INSTALL_DIR>/bobje/serverpids/crystal_cms.pid" -dbinfo "/<INSTALL_DIR>/bobje/enterprise120/linux_x86/_boe_crs.dbinfo" -noauditor -connect 'DSN=CRSDB;UID=xxxxx;PWD=xxxxx;HOSTNAME=127.0.0.1;PORT=3306' -dbdriidFile "/<INSTALL_DIR>/bobje/serverpids/crystal_cms.pid" -dbinfo "/<INSTALL_DIR>/bobje/enterprise120/linux_x86/_boe_crs.dbinfo" -noauditor -connect ***** -dbdriver mysqldatabasesubsystem -fg -reinitializedb -defaultlocale en -quit

The installation log summary was like this:

error Errcode 139: "/home/crystal/crs/DISK_1/bobje/enterprise120/linux_x86//boe_cmsd" -name crs.cms -loggingPath "/home/crystal/crs/DISK_1/bobje/logging/" -pidFile "/home/crystal/crs/DISK_1/bobje/serverpids/crystal_cms.pid" -dbinfo "/home/crystal/crs/DISK_1/bobje/enterprise120/linux_x86/_boe_crs.dbinfo" -no auditor -connect ***** -dbdriver mysqldatabasesubsystem -fg -reinitializedb -defaultlocale en -quit
error PostInstallScripts::WaitForCMS CMS is not started, giving up.

I've tried searching for solution to this problem, and in one forum it is said that the problem was cause by incompatibility with AMD processors (http://www.forumtopics.com/busobj/viewtopic.php?t=130307). The server I'm trying to install CRS to also has AMD processor. If the solution given at the forum is correct, where can I get the replacement file for libWrapCryptoC.so?

Thanks a lot for any help...
IP IP Logged
marvins
Newbie
Newbie


Joined: 09 Feb 2010
Online Status: Offline
Posts: 3
Quote marvins Replybullet Posted: 11 Feb 2010 at 2:13pm
It's alright guys, the problem is already solved.
The assumption that the problem might have related to AMD processor is proven to be correct.

We ask our client to file a support case at SAP customer support webpage and in a short time SAP replied with explanation that one of the installation file (3rd party library libWrapCryptoC.so) has incompatibility problem with AMD Opteron multicore processor. The fix was replacing the file with modified file included in the solution given.

After replacing the file we retried the installation and it was running successfully with no errors.
IP IP Logged
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum