Writing Code
 Crystal Reports Forum : Crystal Reports for Visual Studio 2005-2015 : Writing Code
Message Icon Topic: Visual Studio 2017 Crystal reports issue Post Reply Post New Topic
Author Message
Tvalone
Newbie
Newbie


Joined: 19 Nov 2015
Online Status: Offline
Posts: 1
Quote Tvalone Replybullet Topic: Visual Studio 2017 Crystal reports issue
    Posted: 05 Oct 2020 at 7:53am
I have a .net app written in c#. My desktop was upgraded to a laptop (yay....) The references were copied over and VS was installed on the laptop. I installed crystal on the laptop and added the references back to get the app to build without error. However when I test the app in VS I get this error.

The type initializer for 'CrystalDecisions.CrystalReports.Engine.CRPE' threw an exception

I cannot for the life of me figure out what the issue is.
IP IP Logged
lockwelle
Moderator
Moderator


Joined: 21 Dec 2007
Online Status: Offline
Posts: 4308
Quote lockwelle Replybullet Posted: 05 Oct 2020 at 11:47am
First thing that comes to mind is, is the connection string for the report the same? Perhaps you need to set the connection string for the report in code.

Of course the other thought is, does the report work in the crystal designer? That might help in troubeshooting.

HTH
IP IP Logged
Post Reply Post New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum



This page was generated in 0.031 seconds.