Technical Questions
 Crystal Reports Forum : Crystal Reports 9, X, XI, 2008, 2011 : Technical Questions
Message Icon Topic: Default printer problem Post Reply Post New Topic
Author Message
DeanM
Newbie
Newbie
Avatar

Joined: 14 Sep 2010
Location: Australia
Online Status: Offline
Posts: 3
Quote DeanM Replybullet Topic: Default printer problem
    Posted: 14 Sep 2010 at 7:17pm

I am developing new reports using CR 11. The reports are part of an ERP system. After a report deployment to production environment users can access them by using ERP's interface.  I am using dev. pc for designing the reports and my default printer is e.g. \DEV\PRN1.
Last couple of weeks  users have a problem when trying to print some of the reports. When they click print the default printer is the development printer \DEV\PRN1 not the client's.  This is not the case for all users just some of them.
Does anyone know what is  causing CR  not to pick up the right(default) printer.
The same users can print other reports with no problems. Their Windows settings seems to be ok.

The application does not have functionality to allow users to choose printer from the list prior to printing - just to choose number of pages to be printed.

Also, I noticed that the same  problem is with landscape oriented reports as well as regular A4.

So far I came up with a workaround: - after development a report set Printer settings (No Printer), save and deploy. Then when a user wants to print the report, print option is grayed out, clicks printer settings, un-check  no printer, then hit print button and then CR picks up the right printer(user's default printer).
All printers are network printers.

If someone has an idea how to solve the problem please respond.
Thank you


IP IP Logged
DeanM
Newbie
Newbie
Avatar

Joined: 14 Sep 2010
Location: Australia
Online Status: Offline
Posts: 3
Quote DeanM Replybullet Posted: 27 Sep 2010 at 8:51pm
Does anyone have an idea how to solve the problem or to give me guidelines.
Thanks

Dean
IP IP Logged
DeanM
Newbie
Newbie
Avatar

Joined: 14 Sep 2010
Location: Australia
Online Status: Offline
Posts: 3
Quote DeanM Replybullet Posted: 07 Oct 2010 at 6:35pm

Problem solved!!

1. Install Dummy printer driver (e.g. I installed Microsoft XPS Document Writer and name it DummyCRPrinter)

2. Open the "weird report" change  something insignificant, go to FILE/Print/... choose Dummy printer.. press Apply, Cancel and Save

3. Copy the rpt to prod. srv, run the report from an user site, press Print

The report is picking up the right( users default) printer.Basically it can't find the Dummy printer and then search for default one)

Still, I could not figure out why it is happening with only a few of the  reports that I have developed. I tried different fonts (TTF), margins, printers, landscape orientations, multiple columns ..) but I could not find any pattern.

Many thanks to EdC



IP IP Logged
Post Reply Post New Topic
Printable version Printable version

Forum Jump
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot delete your posts in this forum
You cannot edit your posts in this forum
You cannot create polls in this forum
You cannot vote in polls in this forum



This page was generated in 0.016 seconds.